summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTércio Martins2022-02-28 11:39:49 -0300
committerTércio Martins2022-02-28 11:39:49 -0300
commitc54e8b0c37a0e13a192e64a6ee08a18a7b85e13a (patch)
treec996bcbb23a0e13eec613307e8fabfe4ac39a808 /PKGBUILD
parent8bcc2dcff53cfc3976afd4b02254432c0f894a0e (diff)
downloadaur-c54e8b0c37a0e13a192e64a6ee08a18a7b85e13a.tar.gz
Remove the build parameter "-Wno-stringop-overflow" in the "CMakeLists.txt" file.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 4 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e9a3d61e81f5..4c1677acdd9c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Tércio Martins <echo dGVyY2lvd2VuZGVsQGdtYWlsLmNvbQo= | base64 -d>
-pkgname=olive-git
-_pkgname=${pkgname%-*}
-pkgver=continuous.r1444.ge902507e4
+_pkgname=olive
+pkgname=$_pkgname-git
+pkgver=continuous.r1621.g41a49c488
pkgrel=1
arch=('pentium4' 'x86_64')
pkgdesc="Free non-linear video editor"
@@ -32,11 +32,7 @@ prepare() {
# The OpenTimelineIO library requires some features of C++17 standard.
# Olive uses C++14 by default, preventing the compilation of modules that use OpenTimelineIO.
- sed -i "s/CXX_STANDARD 14/CXX_STANDARD 17/" CMakeLists.txt
-
- # Currently the build crashes in the "ffmpegdecoder.cpp" file (-Werror=stringop-overflow).
- # The build completes normally when this warning is disabled.
- sed -i "/Wshadow/a \ -Wno-stringop-overflow" CMakeLists.txt
+ sed -i "/CXX_STANDARD/ s/14/17/" CMakeLists.txt
}
build() {