summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSR_team2024-03-26 01:09:46 +0200
committerSR_team2024-03-26 01:09:46 +0200
commit21e2ee011e32dab8c1669c519655301eae381b1d (patch)
tree9f0a3aedee209e1e2f1436b3efc1881f9a27fbac /PKGBUILD
parent9dd246d2ed03c6a5be4caa1a61ef8a7c898f1e43 (diff)
downloadaur-ollama-rocm-git.tar.gz
Fix generate version for RC tags
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9e851cb0e17e..bd0327bc59ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=ollama-rocm-git
pkgdesc='Create, run and share large language models (LLMs) with ROCm'
-pkgver=0.1.29.ga5ba0fcf
+pkgver=0.1.30.gc2712b55
pkgrel=1
arch=(x86_64)
url='https://github.com/jmorganca/ollama'
@@ -23,7 +23,7 @@ b2sums=('SKIP'
pkgver() {
cd ${pkgname/-rocm-git}
- local _tag=$(git describe --tags --abbrev=0 | sed "s/^v//")
+ local _tag=$(git describe --tags --abbrev=0 | sed "s/^v//" | sed "s/-rc[0-9]*$//")
local _commit=$(git describe --abbrev=8 --always)
echo "$_tag.g$_commit"
}