summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThatOneCalculator2024-01-02 15:58:16 -0800
committerThatOneCalculator2024-01-02 15:58:16 -0800
commitca079c9472c85dd3034743c9ec2c206f721ca119 (patch)
tree038cd45ad0c8505a4fad8321f237298b7fc7cb40 /PKGBUILD
downloadaur-ca079c9472c85dd3034743c9ec2c206f721ca119.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..159a1fbba47d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: ThatOneCalculator (Kainoa Kanter) <kainoa@t1c.dev>
+_pkgname="ollamamodelupdater"
+pkgname="$_pkgname-bin"
+conflicts=(
+ "$_pkgname"
+ "$_pkgname-bin"
+)
+pkgver=0.5.3
+pkgrel=1
+pkgdesc="Tool to help you update your Ollama models"
+arch=('any')
+url="https://github.com/thatonecalculator/ollamamodelupdater"
+license=('MIT')
+optdepends=(
+ 'ollama: Ollama'
+)
+source=("$_pkgname::$url/releases/download/v"$pkgver"/$_pkgname")
+noextract=()
+options=(!strip)
+sha256sums=('3217e5ee8c79409bcdf4001f7b4e565ee3054aa5397a6486105133a8f8375520')
+
+package() {
+ install -Dm755 "${srcdir}/${_pkgname}" "$pkgdir/usr/bin/$_pkgname"
+}