summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander F. Rødseth2024-10-05 14:39:04 +0200
committerAlexander F. Rødseth2024-10-05 14:39:04 +0200
commitb6224845e87eb31caa427f417f37c22304ae93a1 (patch)
tree54ac8635ef5ea74d7be68eee4bcf0436fcc57bb5 /PKGBUILD
downloadaur-b6224845e87eb31caa427f417f37c22304ae93a1.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4bf7ef75bcb9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+
+pkgname=ollamaurl
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='See what ollama pull would have fetched'
+arch=(x86_64)
+url='https://github.com/xyproto/ollamaurl'
+license=(BSD-3-Clause)
+makedepends=(git go)
+source=("git+$url#tag=v$pkgver")
+b2sums=('5357964be77d0449172199258e6babd37d4526875dbe7ee822260419391a9422e69a8cda0c5386819528f672414f9d9fd63a2486cc0609a71e549ecd2f97a059')
+
+build() {
+ cd $pkgname
+ go build -mod=readonly -v -trimpath -buildmode=pie -ldflags="-s -w -extldflags '$LDFLAGS'"
+}
+
+package() {
+ install -Dm755 -t "$pkgdir/usr/bin" $pkgname/$pkgname
+ install -Dm755 -t "$pkgdir/usr/share/licenses/$pkgname" $pkgname/LICENSE
+}