summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRinasSam2022-01-18 11:29:34 +0300
committerRinasSam2022-01-18 11:29:34 +0300
commitb669617a0d2ce35c7b1adfc8efd570dfd4738664 (patch)
treea403e8704ac2ec98c6970f5ecae1056afb24985b /PKGBUILD
downloadaur-b669617a0d2ce35c7b1adfc8efd570dfd4738664.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83237b73a8d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: RinasSam <samkhaldoon2006@.com>
+pkgname=ollydbg-bin
+pkgver=2.01
+pkgrel=1
+pkgdesc="OllyDbg is a 32-bit assembler level analysing debugger for Microsoft® Windows®."
+arch=(x86_64)
+url="https://www.ollydbg.de/odbg200.zip"
+license=('shareware')
+depends=(wine)
+makedepends=(unzip)
+optdepends=('winetricks: download fonts and other Windows components')
+provides=(ollydbg)
+source=("$url")
+sha256sums=('93dfd6348323db33f2005fc1fb8ff795256ae91d464dd186adc29c4314ed647c')
+noextract=()
+
+
+prepare()
+{
+ unzip odbg200.zip -d ./odbg
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/share/ollydbg"
+
+ install -Dm755 odbg/ollydbg.exe "${pkgdir}/usr/share/ollydbg/ollydbg.exe"
+ install -Dm755 ../ollydbg "${pkgdir}/usr/bin/ollydbg"
+}