summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBruno Miguel Fernandes Silva2020-05-26 21:47:53 +0100
committerBruno Miguel Fernandes Silva2020-05-26 21:47:53 +0100
commit3f9293b08ce208a40dcfb6b03eda8cc8abfa7b01 (patch)
treedd0970e0741e3505f452129542eb5aecd4cbd852 /PKGBUILD
parent9696c32cf8ea15cc5bd4443b527a528a6a00e333 (diff)
downloadaur-omnetpp-qt.tar.gz
Bump to 6.0pre8
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a79a29c9bc26..15e74148d4bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,21 @@
# Maintainer: Bruno Silva <brunofernandes at ua dot pt>
+# Contributor: Thor K. Høgås <thor that-circular-a roht dot no>
pkgname='omnetpp-qt'
-pkgver=6.0pre7
+pkgver=6.0pre8
pkgrel=1
_pkgname='omnetpp'
pkgdesc='OMNeT++ Discrete Event Simulator. OMNeT++ is an extensible, modular, component-based C++ simulation library and framework, primarily for building network simulators: QT version'
url='http://www.omnetpp.org'
license=('custom')
-depends=(libxml2 qt5-base tcl tk jdk-openjdk openmpi libpcap doxygen graphviz clang openscenegraph)
-makedepends=(sh wget qt5-base cmake gcc bison flex perl openscenegraph)
-optdepends=(osgearth)
+depends=(libxml2 qt5-base tcl jdk-openjdk openmpi libpcap doxygen graphviz clang openscenegraph)
+makedepends=(sh wget cmake bison flex perl)
+optdepends=(
+ 'python-numpy: analysing simulation recordings'
+ 'python-matplotlib: analysing simulation recordings'
+ 'python-pandas: analysing simulation recordings'
+ 'python-posix_ipc: analysing simulation recordings'
+ 'osgearth')
arch=('i686' 'x86_64')
provides=('omnetpp')
conflicts=('omnetpp')
@@ -21,7 +27,7 @@ source=(OMNeT++.desktop
sha512sums=('a5772a605592ed2db839609f8298d1d71fb9141eb1b30dac584b788414dfe49b250ba803351a3a84f90c6b89f8e09e7b129a037af17c9b94c22dff2003a5edd8'
'facb711a01c41665c7909f82b4cee65ddee232e0c526f754ce1ab148dbc6c65abb9b24255f985be245fb2c33f91623365eac730ef83cb1a7c595a09726856fa1'
- '338175dfc52998c4cf1b770224f510cc2937ea0dcde690eeb5c59d0cea5a0c52e6e3d36c0b60dbf5280a4071e4a160b4e2f8632f31e09acaf3a5e9f122cb5654')
+ 'fff0f37bba5ed563ae937446c3698f3963671b48bc79c345cd3e237c1dc2441dd5c72a6aaf76ad2d2a2d8c95f70827161cd1bf54ee3a8fabdee147d5cc7b3c49')
build() {
cd ${srcdir}/${_pkgname}-${pkgver}