summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOscar Cowdery Lack2023-07-06 10:14:26 +1000
committerOscar Cowdery Lack2023-07-06 10:14:26 +1000
commitf0f41828d1f15597f041a66845ea8fda30b6de9c (patch)
treefe5c0439f1d53719e7a18b86547d24515ec11b9c /PKGBUILD
parent70ca69c4ad3319b7718b2c5719c5a8b15b8954eb (diff)
downloadaur-f0f41828d1f15597f041a66845ea8fda30b6de9c.tar.gz
1.37.7-2: Add patch for LSP semantic tokens
Fixes compatibility with neovim
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9f134b39e824..517a291bb18d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,27 @@
# Contributor: sixpindin <sixpindin@gmail.com>
pkgname=omnisharp-roslyn
pkgver=1.39.7
-pkgrel=1
+pkgrel=2
pkgdesc="OmniSharp server (STDIO) based on Roslyn workspaces"
arch=('x86_64')
url="https://github.com/OmniSharp/omnisharp-roslyn"
license=('MIT')
depends=('dotnet-sdk')
-source=("https://github.com/OmniSharp/$pkgname/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=('1e5b73e393e62d75e789bae7a19bcdb57548f8966647c533fb8243a42fba0373')
+source=(
+ "https://github.com/OmniSharp/$pkgname/archive/refs/tags/v$pkgver.tar.gz"
+ "https://github.com/OmniSharp/$pkgname/commit/87b61078e86230cac3fca6e64d894ee092776a1c.patch"
+)
+sha256sums=('1e5b73e393e62d75e789bae7a19bcdb57548f8966647c533fb8243a42fba0373'
+ 'da3730a4022c5c50cd8b3575f13603eac6cfd4b81c2591583c33ca6d29e673b8')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
+ for f in ../*.patch
+ do
+ patch --forward --strip=1 --input "$f"
+ done
+
# normally the build sets the version from git, we don't have a git repo so
# just override it manually
sed -i "s/0.0.1-local/$pkgver/" scripts/common.cake