summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsvenschneider2013-12-25 00:28:18 +0100
committersvenschneider2013-12-25 00:28:18 +0100
commitc39c3631137fed91d0049b33a863e7db79e9107d (patch)
treec4657527e411121a3a469843c330347d0d4c119b /PKGBUILD
parent00c037d05c347e702b97526a7ef061880ed94683 (diff)
downloadaur-c39c3631137fed91d0049b33a863e7db79e9107d.tar.gz
[ompl] updated to 0.14.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2022f62f9e37..5c345e646c82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: Sven Schneider <archlinux.sandmann@googlemail.com>
pkgname=ompl
-pkgver=0.12.1
+pkgver=0.14.0
pkgrel=1
pkgdesc="The Open Motion Planning Library (OMPL) consists of many state-of-the-art sampling-based motion planning algorithms"
arch=('i686' 'x86_64')
url="http://ompl.kavrakilab.org/"
license=('BSD')
-depends=('boost-libs' 'python')
+depends=('boost-libs' 'python' 'python-matplotlib')
makedepends=('boost' 'cmake')
optdepends=('py++: Python binding'
'ode: Plan using the Open Dynamics Engine')
source=(https://bitbucket.org/ompl/ompl/downloads/${pkgname}-${pkgver}-Source.tar.gz)
-md5sums=('4e55ad95e45b99d854e70b805f1313f8')
+md5sums=('f022017e24905b2eb7e85d6611ef988f')
build() {
cd "${srcdir}/${pkgname}-${pkgver}-Source"
@@ -29,6 +29,14 @@ build() {
make
}
+check() {
+ cd "${srcdir}/${pkgname}-${pkgver}-Source"
+
+ cd build
+ #make test
+}
+
+
package() {
cd "${srcdir}/${pkgname}-${pkgver}-Source"