summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2023-01-28 11:28:14 -0300
committerDaniel Bermond2023-01-28 11:28:14 -0300
commita4edc8684bf877b726bc114f87238e339cc82c6a (patch)
tree7ed459a834bc7811e65f4d7a1920851f2ab6c391 /PKGBUILD
parente31bba78e7b05aeba59c7fe47911c880338d8c0e (diff)
downloadaur-a4edc8684bf877b726bc114f87238e339cc82c6a.tar.gz
Match latest upstream changes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 08f5853c9308..027930f283ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=onevpl-cpu-git
-pkgver=2023.1.0.r0.g2c8c32a
+pkgver=2023.1.2.r0.g748f32e
pkgrel=1
pkgdesc='oneVPL runtime implementation for CPU (git version)'
arch=('x86_64')
@@ -12,15 +12,12 @@ makedepends=('git' 'cmake' 'meson' 'nasm' 'onevpl' 'python' 'xxhash' 'yasm')
provides=('onevpl-cpu' 'onevpl-runtime')
conflicts=('onevpl-cpu')
source=('git+https://github.com/oneapi-src/oneVPL-cpu.git'
- '010-onevpl-cpu-fix-build.patch'
- '020-onevpl-cpu-disable-gtest-werror.patch')
+ '010-onevpl-cpu-fix-build.patch')
sha256sums=('SKIP'
- 'ee6b8f15e24a6c03337657c3b38eab0b929cc3ec539a94dd8d1d5f9a9b85b3cb'
- 'a0caaa1dd7701b6a13ebe58bc6917c4f10f787f33d4d7e53d52766ddf985b980')
+ 'ee6b8f15e24a6c03337657c3b38eab0b929cc3ec539a94dd8d1d5f9a9b85b3cb')
prepare() {
patch -d oneVPL-cpu -Np1 -i "${srcdir}/010-onevpl-cpu-fix-build.patch"
- patch -d oneVPL-cpu -Np1 -i "${srcdir}/020-onevpl-cpu-disable-gtest-werror.patch"
}
pkgver() {
@@ -59,5 +56,5 @@ check() {
}
package() {
- make -C build DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
}