summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrederik Schwan2021-01-07 01:01:36 +0100
committerFrederik Schwan2021-01-07 01:01:36 +0100
commit3669da6bb207c897975d3da2495b5d9f46c12dd5 (patch)
treec2b7f608123728e1537a6d202cd2fc673d061e8e /PKGBUILD
parent7872df775fc300f2fc29a753e73950c3cc37a495 (diff)
downloadaur-3669da6bb207c897975d3da2495b5d9f46c12dd5.tar.gz
upgpkg: onivim2 0.5.2-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 14 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9ebac9d72721..c6194821b1f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,37 +2,37 @@
# Contributor: Frederick Gnodtke <frederick@gnodtke.net>
pkgname=onivim2
-pkgver=0.5.0
-_commit=c6b7772e18696ac033a4ec3d0e19e6fa4e0249b5
-pkgrel=2
+pkgver=0.5.2
+pkgrel=1
pkgdesc='Native, lightweight modal code editor'
arch=('any')
url='https://github.com/onivim/oni2'
license=('custom:OutrunLabsEULA')
-makedepends=('git' 'esy' 'ragel' 'nodejs' 'wget' 'bzip2' 'fontconfig' 'fuse2' 'glu' 'gtk3' 'harfbuzz'
+makedepends=('esy' 'ragel' 'nodejs' 'wget' 'bzip2' 'fontconfig' 'fuse2' 'glu' 'gtk3' 'harfbuzz'
'libglvnd' 'libice' 'libpng' 'libsm' 'libx11' 'libxcursor' 'libxext' 'libxi' 'libxinerama'
'libxrandr' 'libxt' 'libxxf86vm' 'm4' 'nasm' 'python2' 'clang' 'node-gyp')
options=('!strip')
install='onivim2.install'
-source=("${pkgname}::git+https://github.com/onivim/oni2.git#commit=${_commit}"
+source=("https://github.com/onivim/oni2/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz"
onivim2.install)
-b2sums=('SKIP'
+b2sums=('731bf7710c0427f48db3609a55e21ab5060caae8ce6109ba94e12193de153854a40318c72d021753fdd6adde8f879504d89a886e3210cecbdc3eff15522b39b8'
'd6e0ad8b9755f1e809d5ffc0a23a5f53455468cfed80a2946f9a1901cc3b31b79250b1b418f6cfffe6f14a521f0eaef3370f06e1babeafb84358e7906becbc44')
# set ESY__PREFIX to avoid 5G of dependency cache ending up in ~/.esy
build() {
- cd ${pkgname}
+ cd oni2-${pkgver}
export ESY__PREFIX="${srcdir}"/esy_cache
node install-node-deps.js
esy install
esy bootstrap
esy build
- esy x Oni2 -f --checkhealth
- esy create-release
+ esy '@release' install
+ esy '@release' run -f --checkhealth
+ esy '@release' create
}
check() {
- cd ${pkgname}
+ cd oni2-${pkgver}
export ESY__PREFIX="${srcdir}"/esy_cache
esy '@bench' install
esy '@bench' build
@@ -42,11 +42,11 @@ check() {
package() {
install -dm755 "${pkgdir}"/opt/onivim2
install -dm755 "${pkgdir}"/usr/bin/
- install -Dm644 ${pkgname}/Outrun-Labs-EULA-v1.1.md "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE.txt
+ install -Dm644 oni2-${pkgver}/Outrun-Labs-EULA-v1.1.md "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE.txt
- cd ${pkgname}/_release/
- install -Dm644 Onivim2.AppDir/usr/share/applications/Onivim2.desktop "${pkgdir}"/usr/share/applications/Onivim2.desktop
- install -Dm644 Onivim2.AppDir/usr/share/icons/hicolor/512x512/apps/Onivim2.png "${pkgdir}"/usr/share/pixmaps/Onivim2.png
+ cd oni2-${pkgver}/_release/
+ install -Dm644 Onivim2.AppDir/Onivim2.desktop "${pkgdir}"/usr/share/applications/Onivim2.desktop
+ install -Dm644 Onivim2.AppDir/Onivim2.png "${pkgdir}"/usr/share/pixmaps/Onivim2.png
cp -Lr Onivim2.AppDir/{AppRun,usr} "${pkgdir}"/opt/onivim2
cp -r $(find "${srcdir}"/esy_cache -type d -path '*i/*camomile-opam*/share/camomile') "${pkgdir}"/opt/onivim2/usr/share
ln -s /opt/onivim2/AppRun "${pkgdir}"/usr/bin/Oni2