summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph Haag2021-09-03 01:50:01 +0200
committerChristoph Haag2021-09-03 01:50:01 +0200
commit12c5cbe023a4a324c97cdd871c34c2cf56b0ce1f (patch)
tree081ab3d1a044ada0ca856d1d146802fd82feaf4a /PKGBUILD
parent55b296659f9d5d3d02c60ecee8da1b832e18eec8 (diff)
downloadaur-12c5cbe023a4a324c97cdd871c34c2cf56b0ce1f.tar.gz
add pkgver
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c4b87b055d6a..eb8c2e80d62f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=onnxruntime
pkgname=onnxruntime-git
-pkgver=0
+pkgver=orttraining_rc2.r2552.g5f30be3e92
pkgrel=1
pkgdesc="cross-platform inference and training machine-learning accelerator."
arch=('x86_64')
@@ -26,6 +26,11 @@ prepare() {
git submodule update --init --recursive
}
+pkgver() {
+ cd "$_pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
build() {
cd "$_pkgname"
# ./build.sh --config RelWithDebInfo --build_shared_lib --parallel