summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorinhzus2022-08-28 06:47:47 +0000
committerinhzus2022-08-28 06:47:47 +0000
commit0b3a072123d847afad6e782fb274678fbf675eed (patch)
tree61b810a073e1edb72c88a96e3f5670d3afa57764 /PKGBUILD
parentbf5a627cf4183aa12025305cbf803fa60868176d (diff)
downloadaur-0b3a072123d847afad6e782fb274678fbf675eed.tar.gz
add onnxruntime core headers
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 02c2a64def7e..6b20f11e6f09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,14 +14,19 @@ replaces=()
backup=()
options=()
# install=
-source=("https://github.com/microsoft/onnxruntime/releases/download/v${pkgver}/onnxruntime-linux-x64-${pkgver}.tgz")
+source=("https://github.com/microsoft/onnxruntime/releases/download/v${pkgver}/onnxruntime-linux-x64-${pkgver}.tgz"
+ "$pkgname.zip::https://github.com/microsoft/onnxruntime/archive/refs/heads/main.zip")
noextract=()
-md5sums=('SKIP')
+md5sums=('SKIP'
+ 'SKIP')
# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
# a description of each element in the source array.
package() {
- install -D "${srcdir}/onnxruntime-linux-x64-${pkgver}/include"/* -t "${pkgdir}/usr/include"
- install -D "${srcdir}/onnxruntime-linux-x64-${pkgver}/lib"/* -t "${pkgdir}/usr/lib"
-} \ No newline at end of file
+ mkdir -p "${pkgdir}/usr/include"
+ mkdir -p "${pkgdir}/usr/lib"
+ cp -r "${srcdir}/onnxruntime-main/include"/* "${pkgdir}/usr/include/"
+ cp "${srcdir}/onnxruntime-linux-x64-${pkgver}/include"/* "${pkgdir}/usr/include/"
+ cp "${srcdir}/onnxruntime-linux-x64-${pkgver}/lib"/* "${pkgdir}/usr/lib/"
+}