summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwhoisYoges2022-10-13 15:32:26 +0545
committerwhoisYoges2022-10-13 15:32:26 +0545
commit0be5383d28185872a368ffeddde0179b1e53b8f8 (patch)
tree54e169c4278bcf0b4276819f05ccf5598a6fa42e /PKGBUILD
downloadaur-0be5383d28185872a368ffeddde0179b1e53b8f8.tar.gz
First release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dad2d818c7b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Castor < whoisyoges at castorisdead dot xyz >
+
+pkgname=onthespot-git
+_pkgname=onthespot
+pkgver=0.4
+pkgrel=1
+pkgdesc="A qt based free spotify downloader written in python."
+arch=('i686' 'x86_64')
+url="https://github.com/casualsnek/onthespot"
+license=('GPL2')
+depends=('ffmpeg')
+makedepends=('git' 'python3' 'bash')
+provides=('onthespot')
+conflicts=('onthespot-git' 'onthespot')
+options=(!strip !emptydirs)
+source=("${_pkgname}::git+${url}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --tags | sed 's/^v//;s/-/+/g'
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ bash build_linux.sh
+}
+
+package() {
+ cd "${srcdir}/$_pkgname/dist"
+ install -Dm755 ./onthespot_linux "${pkgdir}/usr/local/bin/onthespot"
+}