summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNick Cao2020-03-11 08:17:39 +0800
committerNick Cao2020-03-11 08:17:39 +0800
commitf4eb26245e448abd473ac1e4057f8be5b52de177 (patch)
tree522682c4ad3bcd6cb1afa0ff99c4ed0d29f2f01d /PKGBUILD
parent3a6dcdb577bfa3c874894889315f0c940174bf73 (diff)
downloadaur-f4eb26245e448abd473ac1e4057f8be5b52de177.tar.gz
bump version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 8 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 20bb45f8db0f..abeb35152161 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Previous Maintainer: Julien Nicoulaud <julien dot nicoulaud at gmail dot com>
pkgname=oomd
-pkgver=0.2.0
-pkgrel=7
+pkgver=0.3.2
+pkgrel=1
pkgdesc='A userspace out-of-memory killer.'
arch=('x86_64')
url='https://github.com/facebookincubator/oomd'
@@ -15,24 +15,19 @@ checkdepends=('gtest' 'gmock')
install="${pkgname}.install"
provides=("${pkgname}")
conflicts=("${pkgname}-git")
-backup=("etc/${pkgname}.json")
-source=("https://github.com/facebookincubator/${pkgname}/archive/v${pkgver}.tar.gz"
- "${pkgname}.service"
- "${pkgname}.default")
-sha512sums=('f6ce5483d96ca54558642ec60ce28b6f5ad63460c3af2cda17fdbdea125bc31236a2468db7125077d2a68ca951a21b1ad853e31869fe957ab261b5ec55e7992c'
- '0515f2ec37c654830e7b14ac1fd721eda4932e152502e454e06df5ab01aab1a1d15423c1bc8d593412cd7616a441d46dc1b05564f79b157045fd69c0555da20b'
- '1db7c71b1b1d21ba5ebe10add5b1b37c6df2169f24938f91170833eddb40e7acf58726cb01e528f340d66ada18b557b26f9c07b542a253d15f04c440e7cd1eb8')
+backup=("etc/${pkgname}/${pkgname}.json")
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/facebookincubator/${pkgname}/archive/v${pkgver}.tar.gz")
+sha512sums=('42187233ad4b10feeb9666b56e0fa3fbb04dda824184b60eb6f69052913b44127331da8901e1ef5e2c723989f5f1ccd4c28f3ffdae3f02e359cc4e6d288b5fe3')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
-
# build system expects the directory to be named "oomd"
ln -sfT "${pkgname}-${pkgver}" "${srcdir}/${pkgname}"
}
build() {
cd "${srcdir}/${pkgname}"
- meson --prefix "${pkgdir}/usr" build && ninja -C build
+ meson build --prefix=/usr && ninja -C build
}
check() {
@@ -42,8 +37,6 @@ check() {
package() {
cd "${srcdir}/${pkgname}"
- ninja -C build install
- install -Dm644 "build/${pkgname}.json" "${pkgdir}/etc/${pkgname}.json"
- install -Dm644 "${srcdir}/${pkgname}.service" "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
- install -Dm644 "${srcdir}/${pkgname}.default" "${pkgdir}/etc/default/${pkgname}"
+ DESTDIR="${pkgdir}" ninja -C build install
}
+