summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJianqiu Zhang2018-08-11 10:04:47 +0800
committerJianqiu Zhang2018-08-11 10:13:46 +0800
commit0980302979182c673641b9f7ac80f3ade10ed6fe (patch)
treee1a96dd689481c840c51bd0bfec0683c3a8d479e /PKGBUILD
downloadaur-0980302979182c673641b9f7ac80f3ade10ed6fe.tar.gz
package for oomd-git
Signed-off-by: Jianqiu Zhang <zhangjianqiu13@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ecb6def8b8ec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Jianqiu Zhang <void001@archlinuxcn.org>
+
+
+pkgname=oomd-git
+pkgver=20180811
+pkgrel=1
+pkgdesc='A userspace out-of-memory killer'
+arch=('x86_64')
+url="https://github.com/facebookincubator/oomd"
+license=('GPL2')
+depends=('jsoncpp')
+makedepends=('meson' 'ninja' 'git' 'jsoncpp')
+md5sums=('SKIP'
+ '9b65f349870dd3e9052da6e94212bd4e')
+
+source=(
+ "oomd::git+https://github.com/facebookincubator/oomd.git"
+ "fix-meson-no-install.patch"
+)
+
+
+prepare() {
+ echo "Fix the install patch error"
+ cp fix-meson-no-install.patch $srcdir/oomd/
+ cd $srcdir/oomd/
+ patch -p1 < fix-meson-no-install.patch
+}
+
+build() {
+ cd $srcdir/oomd
+ meson --prefix "$pkgdir/usr" build && ninja -C build
+}
+
+package() {
+ cd $srcdir/oomd
+ ninja -C build install
+ install -Dm644 $srcdir/oomd/example/oomd.json $pkgdir/etc/oomd.json.example
+}