summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntonin Décimo2021-01-31 11:41:24 +0100
committerAntonin Décimo2021-01-31 11:41:24 +0100
commit62cfa7cbb8d90828ecdf8722884bb45ef58df6be (patch)
tree3acc29a2624365f3e2c559570627cb3e55d63748 /PKGBUILD
parent9bc0f3a719fca42b594316e0ce4701dd4f7964ab (diff)
downloadaur-opam-git.tar.gz
Use pkgname without git suffix
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9311e26dcb67..69b133d00b15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,10 @@
# Contributor: Vincent Bernardoff <vb@luminar.eu.org>
# Contributor: Raphaël Proust <raphlalou@gmail.com>
-pkgname=opam-git
-pkgver=2.1.0.beta2.r165.g1138d481
-pkgrel=3
+_pkgname=opam
+pkgname=$_pkgname-git
+pkgver=2.1.0.beta4.r13.g6929b39c
+pkgrel=1
pkgdesc='OCaml package manager'
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
url='https://opam.ocaml.org/'
@@ -17,18 +18,18 @@ optdepends=(
'mercurial: For downloading packages with mercurial'
'rsync: For downloading packages with rsync'
)
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
-source=("${pkgname%-git}"::'git+git://github.com/ocaml/opam.git')
+provides=(_$pkgname)
+conflicts=($_pkgname)
+source=('git://github.com/ocaml/opam.git')
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
+ cd "$srcdir/$_pkgname"
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$srcdir/${pkgname%-git}"
+ cd "$srcdir/$_pkgname"
# A clean environment seems mandatory to avoid conflicts with
# existing installation of Opam packages. This may cause surprises
# if you have a peculiar customization of your OCaml/Opam setup.
@@ -37,6 +38,6 @@ build() {
}
package() {
- cd "$srcdir/${pkgname%-git}"
+ cd "$srcdir/$_pkgname"
make DESTDIR="$pkgdir" install
}