summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntonin Décimo2020-12-07 18:44:18 +0100
committerAntonin Décimo2020-12-07 18:46:36 +0100
commit288c1f7eb298462bd73c06673994009b73dc396b (patch)
tree318d33b186123a491e7cabe5122f65832814b3e3 /PKGBUILD
parent84f0f4d575a2620f328ea50816db835fc299ea08 (diff)
downloadaur-288c1f7eb298462bd73c06673994009b73dc396b.tar.gz
Update to Opam 2.1.0.beta2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 22 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2a4b80bc1d88..1429f638c064 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,39 @@
-# Maintainer: Vincent Bernardoff <vb@luminar.eu.org>
+# Maintainer: Antonin Décimo <antonin dot decimo at gmail dot com>
+# Contributor: Vincent Bernardoff <vb@luminar.eu.org>
# Contributor: Raphaël Proust <raphlalou@gmail.com>
pkgname=opam-git
-pkgver=1.1.0.484.g692cf53
+pkgver=2.1.0.beta2.r165.g1138d481
pkgrel=1
-pkgdesc="OCaml Package Manager"
+pkgdesc='OCaml package manager'
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
-url="https://opam.ocaml.org"
-license=('GPL')
-depends=('ocaml' 'aspcud')
+url='https://opam.ocaml.org/'
+license=(GPL)
+depends=(bubblewrap ocaml-compiler-libs unzip)
makedepends=('git' 'curl')
-provides=('opam')
-conflicts=('opam')
-install='opam-git.install'
-source=("$pkgname"::'git+git://github.com/ocaml/opam' 'opam-git.install')
-md5sums=('SKIP'
- 'e26e35d3f858c0b5474b778821f9d2e8')
+optdepends=(
+ 'darcs: For downloading packages with darcs'
+ 'git: For downloading packages with git'
+ 'mercurial: For downloading packages with mercurial'
+ 'rsync: For downloading packages with rsync'
+)
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname"::'git+git://github.com/ocaml/opam.git')
+sha256sums=('SKIP')
pkgver() {
- cd "$pkgname"
- local ver="$(git describe --always)"
- printf "%s" "${ver//-/.}"
+ cd "$pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$pkgname"
+ cd "$srcdir/${pkgname%-git}"
./configure --prefix=/usr
- make lib-ext -j 1
- make -j 1
+ make lib-ext all
}
package() {
- cd "$pkgname"
+ cd "$srcdir/${pkgname%-git}"
make DESTDIR="$pkgdir" install
}
-
-# vim:set ts=2 sw=2 et: