summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntonin Décimo2020-12-07 20:28:36 +0100
committerAntonin Décimo2020-12-07 20:28:36 +0100
commit9bc0f3a719fca42b594316e0ce4701dd4f7964ab (patch)
tree801125cf1de596caaf42ccd9f10fa68672d4bdd0 /PKGBUILD
parent8ba691292cce924018a582ca6a8d737e9685cd6f (diff)
downloadaur-9bc0f3a719fca42b594316e0ce4701dd4f7964ab.tar.gz
Build in a clean environment
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bd9644da6216..9311e26dcb67 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=opam-git
pkgver=2.1.0.beta2.r165.g1138d481
-pkgrel=2
+pkgrel=3
pkgdesc='OCaml package manager'
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
url='https://opam.ocaml.org/'
@@ -29,8 +29,11 @@ pkgver() {
build() {
cd "$srcdir/${pkgname%-git}"
- ./configure --prefix=/usr
- make lib-ext all
+ # A clean environment seems mandatory to avoid conflicts with
+ # existing installation of Opam packages. This may cause surprises
+ # if you have a peculiar customization of your OCaml/Opam setup.
+ env -i PATH=/usr/bin LANG=$LANG ./configure --prefix=/usr
+ env -i PATH=/usr/bin LANG=$LANG make lib-ext all
}
package() {