summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJames Spencer2015-06-13 15:28:39 +0100
committerJames Spencer2015-06-13 15:28:39 +0100
commit64df58180aeba4c024dd44da4e66e4d44a082ef9 (patch)
tree58728402746171b9e5346afbd76d32c2a4951bc4 /PKGBUILD
downloadaur-64df58180aeba4c024dd44da4e66e4d44a082ef9.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f70bca98890
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: James Spencer <james.s.spencer@gmail.com>
+
+pkgname=opari2
+pkgver=1.1.3
+pkgrel=1
+pkgdesc="Instrumentation tool for OpenMP and hybrid codes."
+arch=('i686' 'x86_64')
+url="http://www.vi-hps.org/projects/score-p/"
+license=('BSD')
+depends=('gcc-fortran')
+source=(http://www.vi-hps.org/upload/packages/$pkgname/$pkgname-$pkgver.tar.gz)
+sha1sums=('f39170c3cb5a4c9e63750026e426e61dbe7bc240')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+}