summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Gerber2016-01-02 15:55:38 +0100
committerMichael Gerber2016-01-02 15:55:38 +0100
commitb0d9204d746e94b609eac487c158ead50e3f6d34 (patch)
tree1c523d3bf5b71ca529b7327a45051c6afbaab527 /PKGBUILD
downloadaur-open-xchange-drive.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..72e28385b6b3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Michael Gerber <aur at lynxcore dot org >
+pkgname=open-xchange-drive
+pkgver=7.8.0
+pkgrel=6
+pkgdesc='Server module for Open-Xchange Drive file synchronization'
+groups=()
+install='open-xchange-drive.install'
+arch=('any')
+url='http://www.ox.io/'
+license=('GPLv2')
+depends=('open-xchange-core')
+makedepends=()
+conflicts=()
+provides=('open-xchange-drive')
+source=('https://software.open-xchange.com/products/appsuite/stable/debs/DebianJessie/all/open-xchange-drive_7.8.0-6_all.deb')
+sha256sums=('fc3b4c3dd8459b3e7f32dc3f4b88ccab9780c21b55de9a63db87fefff7a1c5bd')
+
+package() {
+ if test -f "data.tar.xz"; then
+ tar xf data.tar.xz
+ cp -a $(find . -mindepth 1 -maxdepth 1 -type d) "$pkgdir"
+ fi
+
+ if test -f "data.tar.gz"; then
+ tar xf data.tar.gz
+ cp -a $(find . -mindepth 1 -maxdepth 1 -type d) "$pkgdir"
+ fi
+}