summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Gerber2016-01-02 17:25:32 +0100
committerMichael Gerber2016-01-02 17:25:32 +0100
commit8909a66f5c615b8c0ce7bc2c1d7f20e7c746db7d (patch)
tree3061f1ca1bafdcea39bbfc536db9535d9e16ea51 /PKGBUILD
downloadaur-open-xchange-realtime-json.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0454df674e1e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Michael Gerber <aur at lynxcore dot org >
+pkgname=open-xchange-realtime-json
+pkgver=7.8.0
+pkgrel=6
+pkgdesc='Realtime channel implementation for frequent polling'
+groups=()
+install='open-xchange-realtime-json.install'
+arch=('any')
+url='http://www.ox.io/'
+license=('GPLv2')
+depends=('open-xchange-realtime-core' 'open-xchange-grizzly')
+makedepends=()
+conflicts=()
+provides=('open-xchange-realtime-json')
+source=('https://software.open-xchange.com/products/appsuite/stable/debs/DebianJessie/all/open-xchange-realtime-json_7.8.0-6_all.deb')
+sha256sums=('1fd742e2d137775d89f53ae9371a5f02227a67a674c9cd451a19fc19db70903d')
+
+package() {
+ if test -f "data.tar.xz"; then
+ tar xf data.tar.xz
+ cp -a $(find . -mindepth 1 -maxdepth 1 -type d) "$pkgdir"
+ fi
+
+ if test -f "data.tar.gz"; then
+ tar xf data.tar.gz
+ cp -a $(find . -mindepth 1 -maxdepth 1 -type d) "$pkgdir"
+ fi
+}