summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorZhirui Dai2024-03-31 01:52:39 -0700
committerZhirui Dai2024-03-31 01:52:39 -0700
commit1522f4db1de697d704acf0b8f27a19b953e35da6 (patch)
treea2816451fa37e8ccdfa8d50f1857abb8c1e8e749 /PKGBUILD
parent64ca6cec27698cb3589c3d06ab2b24aa3ede712d (diff)
downloadaur-1522f4db1de697d704acf0b8f27a19b953e35da6.tar.gz
set GLIBCXX_USE_CXX11_ABI=OFF to make open3d compatible with other python packages like PyTorch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5a7a021e0a01..663af9acf041 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgbase=open3d
pkgname=( {,python-}open3d python-py3d )
pkgver=0.18.0
-pkgrel=3
+pkgrel=4
epoch=1
pkgdesc="A Modern Library for 3D Data Processing"
arch=('x86_64')
@@ -58,7 +58,8 @@ function build() {
-DBUILD_SHARED_LIBS=ON \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_C_COMPILER=/usr/bin/gcc-12 \
- -DCMAKE_CXX_COMPILER=/usr/bin/g++-12
+ -DCMAKE_CXX_COMPILER=/usr/bin/g++-12 \
+ -DGLIBCXX_USE_CXX11_ABI=OFF
make -j$(nproc)
}