summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Lass2020-05-19 15:28:35 +0200
committerMichael Lass2020-05-19 16:28:18 +0200
commit6ffc7d6ad766197be8c759c412932a99f2182fbc (patch)
treea8b389c564900ac6eb9b44df8bf01775ea404478 /PKGBUILD
parent89b882d7b528a066b35924a902466d7cd63a7bcb (diff)
downloadaur-6ffc7d6ad766197be8c759c412932a99f2182fbc.tar.gz
Update to actual 1.8.6pre2 and fix build with GCC 10
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 10 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5d42dc522a4d..288fc0aa8006 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# https://github.com/michaellass/AUR
pkgname=openafs
-pkgver=1.8.6pre1
+pkgver=1.8.6pre2
pkgrel=1
pkgdesc="Open source implementation of the AFS distributed file system"
arch=('i686' 'x86_64' 'armv7h')
@@ -24,19 +24,13 @@ install=openafs.install
source=(http://openafs.org/dl/openafs/candidate/${pkgver}/${pkgname}-${pkgver}-src.tar.bz2
http://openafs.org/dl/openafs/candidate/${pkgver}/${pkgname}-${pkgver}-doc.tar.bz2
tmpfiles.d-openafs.conf
- 0001-LINUX-Avoid-building-rand-fortuna-kernel.o.patch
- 0002-LINUX-5.6-define-time_t-and-use-timespec-timespec64.patch
- 0003-Update-NEWS-for-OpenAFS-1.8.6pre2.patch
- 0004-Make-OpenAFS-1.8.6pre2.patch
- 0005-Adjust-RedHat-config-and-service-files.patch)
-sha256sums=('4ae020010632fbc9198be94ea97d6f6301c813227117fd8a28e15f32e8f58517'
- '4aaea8d80c0df1947a843093385a10adc50a191f4fb3d6285f27e514da965135'
+ 0001-Temporary-fix-for-compilation-with-GCC-10.patch
+ 0002-Adjust-RedHat-config-and-service-files.patch)
+sha256sums=('ae1aa62c977fc13d61df1f9822ff75af301c50f8ff0528c8fd1f2914fffafcf5'
+ '262117808a28512ba9be76a40130a7e60c1c468e1d185275ab83cb45e740c8ae'
'18d7b0173bbffbdc212f4e58c5b3ce369adf868452aabc3485f2a6a2ddb35d68'
- '3639bc58cf7896f4b3c5a0c93f8a7a65a119dbd6eff0cb55597e3762ac2e6b3f'
- 'a75af2f13ac35e4d324183ac76727f53b832e7fa3b16f4983b48226a0c5452d2'
- '5fc7fc6c44f950c99a1ad9629d6fe56bd88bd1f0b2f2ce3922939e7d073790c9'
- 'd15fd705b0b24280c06ca8f2cb6d5c08bcb492cdb1f8f509de1d2c076c01c99d'
- '0e696e44a434dab91e8ab9755687169896a6739beadd0eba727b4e9bd07b3681')
+ 'ebd26d2434689ca7f1c71434cf9a524cf8f2457faa2ba93b90723f4244092451'
+ '86b0560369e0d41e6c384fcdeed4ddf2d0a1da3e2ca55145ca9b1c0f2611e22a')
# If you need the kauth tools set this to 1. But be aware that these tools
# are considered insecure since 2003! This also affects the PAM libs.
@@ -45,14 +39,11 @@ ENABLE_KAUTH=0
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
- # Imitate what is likely to become 1.8.6pre2
- patch -p1 < "${srcdir}/0001-LINUX-Avoid-building-rand-fortuna-kernel.o.patch"
- patch -p1 < "${srcdir}/0002-LINUX-5.6-define-time_t-and-use-timespec-timespec64.patch"
- patch -p1 < "${srcdir}/0003-Update-NEWS-for-OpenAFS-1.8.6pre2.patch"
- patch -p1 < "${srcdir}/0004-Make-OpenAFS-1.8.6pre2.patch"
+ # Fix compilation with GCC 10 (see https://bugs.gentoo.org/706738 and https://gerrit.openafs.org/14106)
+ patch -p1 < "${srcdir}/0001-Temporary-fix-for-compilation-with-GCC-10.patch"
# Adjust RedHat config and service files to our needs
- patch -p1 < "${srcdir}/0005-Adjust-RedHat-config-and-service-files.patch"
+ patch -p1 < "${srcdir}/0002-Adjust-RedHat-config-and-service-files.patch"
# Only needed when changes to configure were made
./regen.sh -q