summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Laß2022-07-21 23:10:50 +0200
committerMichael Laß2022-07-26 07:12:56 +0200
commit89c78fad2ae582ee45af496094744892734bac4f (patch)
tree49ea34e1f7be1716c970a44184449019af9f2a24 /PKGBUILD
parent7e729c48fb070c2430e27c2b2e22506a9ec0044e (diff)
downloadaur-89c78fad2ae582ee45af496094744892734bac4f.tar.gz
Use patches likely to end up in next release
Instead of rolling our own set of patches for supporting newer kernels, apply all changes that are accepted or likely to be accepted for the next OpenAFS stable release. On top of that, backport patches for Linux 5.19.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 26 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 39d33ab6f4a6..296f27fd5aa9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=openafs
pkgver=1.8.8.1
-pkgrel=1
+pkgrel=2
pkgdesc="Open source implementation of the AFS distributed file system"
arch=('i686' 'x86_64' 'armv7h')
url="http://www.openafs.org"
@@ -24,11 +24,21 @@ install=openafs.install
source=(http://openafs.org/dl/openafs/${pkgver}/${pkgname}-${pkgver}-src.tar.bz2
http://openafs.org/dl/openafs/${pkgver}/${pkgname}-${pkgver}-doc.tar.bz2
tmpfiles.d-openafs.conf
- 0001-Adjust-RedHat-config-and-service-files.patch)
+ 0001-Accepted-changes-for-openafs-stable-1_8_x.patch.gz
+ 0002-Pending-changes-for-openafs-stable-1_8_x.patch.gz
+ 0003-Linux-Introduce-file-mapping-readpage-helpers.patch
+ 0004-Linux-5.19-Rename-aops-readpage-to-read_folio.patch
+ 0005-Linux-5.19-Remove-flags-from-aops-write_begin.patch
+ 0006-Adjust-RedHat-config-and-service-files.patch)
sha256sums=('e7c4bed7075bcd6402e3f0c2d5b9dbe76ad2ee3c5fd5ddc3973a3356ca23ef44'
'cb5ecedc2e164bea3b48c6b2c9d6f1c36bfde91d068a4c62a9c885df48fe8e6b'
'18d7b0173bbffbdc212f4e58c5b3ce369adf868452aabc3485f2a6a2ddb35d68'
- 'e93cb374badf24662ebead212525e386cdc05e32c7606ec7b4c0da2e3f103ae5')
+ '8e9fd9e37fe55a379534f4ccb48be9f37c141e13e7f28aa834793eaa7ade1bd4'
+ 'eb78d128fa3bfad82e40c9077ff972f0dd34a9745a6463ae2ac0f6cb9d912853'
+ '0e902a093d5bad45f422ef1fc47c686503315fa3049f304eadb8b9dae6be8027'
+ '0bb7ac77fa5d3d42bd78f67974ecbcc7cb8973e2859d74c361cb5fa18275cb8e'
+ '7c7c6d9e76b436f95ba46138b979694cb50ff33eba2de82f1f5d426213f1768c'
+ 'd5b8223ab81a84639bd5614dffe67724640f2ea437374d2b0f2d066bd53cde2d')
# If you need the kauth tools set this to 1. But be aware that these tools
# are considered insecure since 2003! This also affects the PAM libs.
@@ -37,11 +47,22 @@ ENABLE_KAUTH=0
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
+ # Changes that have been accepted for OpenAFS 1.8.x
+ zcat "${srcdir}"/0001-Accepted-changes-for-openafs-stable-1_8_x.patch.gz | patch -p1
+
+ # Changes likely to be accepted for OpenAFS 1.8.x
+ zcat "${srcdir}"/0002-Pending-changes-for-openafs-stable-1_8_x.patch.gz | patch -p1
+
+ # Changes to support Linux 5.19
+ patch -p1 < "${srcdir}"/0003-Linux-Introduce-file-mapping-readpage-helpers.patch
+ patch -p1 < "${srcdir}"/0004-Linux-5.19-Rename-aops-readpage-to-read_folio.patch
+ patch -p1 < "${srcdir}"/0005-Linux-5.19-Remove-flags-from-aops-write_begin.patch
+
# Adjust RedHat config and service files to our needs
- patch -p1 < "${srcdir}"/0001-Adjust-RedHat-config-and-service-files.patch
+ patch -p1 < "${srcdir}"/0006-Adjust-RedHat-config-and-service-files.patch
# Only needed when changes to configure were made
- # ./regen.sh -q
+ ./regen.sh -q
}
build() {