summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Lass2017-06-01 20:42:59 +0200
committerMichael Lass2017-06-01 20:43:56 +0200
commit6341094032bdd51f7c94c93f468b67ba22a2184f (patch)
treefe25c92811c6c1a12f1990d1bb07393a4dad6772 /PKGBUILD
parent496dd4f59bd17d5bcbfddea9fd03dd1a367bd4d3 (diff)
downloadaur-6341094032bdd51f7c94c93f468b67ba22a2184f.tar.gz
Add fix for gcc bug
The following error flaws the check for gid in the group_info struct. For now we just set the corresponding define manually. /var/lib/dkms/openafs/1.6.20.2/build/conftest.dir/conftest.c:43:8: internal compiler error: Segmentation fault struct group_info _test; printk("%x\n", &_test.gid); ^~~~~~~~~~
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 10 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dc8496fdd46c..52c6874b1da3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -42,6 +42,16 @@ build() {
--with-linux-kernel-packaging \
--with-linux-kernel-build="/usr/lib/modules/${_kernelver}/build"
+ # It seems like gcc is not happy with the code wich tests for the presence
+ # of gid in the group_info struct:
+ #
+ # /var/lib/dkms/openafs/1.6.20.2/build/conftest.dir/conftest.c:43:8: internal compiler error: Segmentation fault
+ # struct group_info _test; printk("%x\n", &_test.gid);
+ # ^~~~~~~~~~
+ #
+ # Until this is fixed, we just force the result.
+ echo "#define STRUCT_GROUP_INFO_HAS_GID" >> ${srcdir}/${_srcname}-${pkgver}/src/config/afsconfig.h
+
make only_libafs
}