summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Lass2020-06-08 18:06:36 +0200
committerMichael Lass2020-06-08 18:06:36 +0200
commit75f1ca29917e619ab53e8909f9811d647351a2e6 (patch)
tree6e4b11ade98ead07282cd236e1cd278b1b0833d3 /PKGBUILD
parentccdc867844c69a71ae74e7d5240f8ae98d123c3c (diff)
downloadaur-75f1ca29917e619ab53e8909f9811d647351a2e6.tar.gz
Compatibility with Linux 5.7
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8203bfe52cf1..8996ad779ed9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=openafs-modules-dkms
_srcname=openafs
pkgver=1.8.6pre2
-pkgrel=1
+pkgrel=2
pkgdesc="Kernel module for OpenAFS (dkms)"
arch=('i686' 'x86_64' 'armv7h')
url="http://www.openafs.org"
@@ -18,10 +18,14 @@ conflicts=('openafs-features-libafs' 'openafs-modules' 'openafs<1.6.6-2')
options=(!emptydirs)
source=("http://openafs.org/dl/openafs/candidate/${pkgver}/${_srcname}-${pkgver}-src.tar.bz2"
"dkms.conf"
- 0001-Temporary-fix-for-compilation-with-GCC-10.patch)
+ 0001-Temporary-fix-for-compilation-with-GCC-10.patch
+ 0002-libafs-Abstract-the-Linux-lru-cache-interface.patch
+ 0003-LINUX-5.7-replace-__pagevec_lru_add-with-lru_cache_a.patch)
sha256sums=('ae1aa62c977fc13d61df1f9822ff75af301c50f8ff0528c8fd1f2914fffafcf5'
'5ea5e184f9b44f5ed45817d2b5a10149d15c8c54f49e0b5b4b773652673cb9b0'
- 'ebd26d2434689ca7f1c71434cf9a524cf8f2457faa2ba93b90723f4244092451')
+ 'b067b59bf856d15ded1ee786d303eb7b7ff47edb5b3e078b1d43862b8db62368'
+ '22d94f69864cde0027716e8bb251406b9fe3745aa6b0f8a16fcb94748e8c3925'
+ 'dec56eff34fd1ea492a12d90558edfd4a46b82f203f6e7a1fd7543eb1fb0bc99')
prepare() {
cd "${srcdir}/${_srcname}-${pkgver}"
@@ -29,6 +33,10 @@ prepare() {
# Fix compilation with GCC 10 (see https://bugs.gentoo.org/706738 and https://gerrit.openafs.org/14106)
patch -p1 < "${srcdir}/0001-Temporary-fix-for-compilation-with-GCC-10.patch"
+ # Fix compatibility with Linux 5.7 (https://gerrit.openafs.org/14209 and https://gerrit.openafs.org/14210)
+ patch -p1 < "${srcdir}/0002-libafs-Abstract-the-Linux-lru-cache-interface.patch"
+ patch -p1 < "${srcdir}/0003-LINUX-5.7-replace-__pagevec_lru_add-with-lru_cache_a.patch"
+
# Only needed when changes to configure were made
./regen.sh -q
}