summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEric Berquist2020-03-22 14:01:00 -0400
committerEric Berquist2020-03-22 14:01:00 -0400
commit3d1100ce913bc09584a825cd7532a6f5e130003d (patch)
tree19d8ace39e6ea3d9098da625b21a573b86231ac4 /PKGBUILD
parent2633c7f8d76c85770f71ce3f79655f0360465443 (diff)
downloadaur-openbabel-git.tar.gz
version bump: 2.4.90 -> 3.0.90
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD57
1 files changed, 30 insertions, 27 deletions
diff --git a/PKGBUILD b/PKGBUILD
index decc4067e339..97551e9b4a19 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,20 @@
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Damir Perisa <damir.perisa@bluewin.ch>
-pkgname=openbabel-git
-_name=openbabel
-pkgver=2.4.90.r5252.722b2134
+pkgbase=openbabel
+pkgname=(${pkgbase}-git python-${pkgbase}-git)
+pkgver=3.0.90.r5774.686ee22f2
pkgrel=1
-pkgdesc="A library designed to interconvert between many file formats used in molecular modeling and computational chemistry (git version, builds Python bindings)"
-arch=("x86_64")
-url="https://github.com/openbabel/openbabel"
-license=("GPL")
-depends=("libxml2" "libsm" "python" "wxgtk")
-makedepends=("git" "cmake" "eigen" "boost" "swig")
-provides=("${_name}")
-conflicts=("${_name}" "python-${_name}")
-source=("${_name}::git+https://github.com/openbabel/openbabel.git#branch=master")
+pkgdesc='A library designed to interconvert between many file formats used in molecular modeling and computational chemistry (git version, builds Python bindings)'
+arch=('x86_64')
+url='https://github.com/openbabel/openbabel'
+license=('GPL')
+makedepends=('git' 'cmake' 'eigen' 'wxgtk3' 'boost' 'python' 'swig' 'maeparser' 'rapidjson')
+source=("${pkgbase}::git+https://github.com/openbabel/openbabel.git#branch=master")
md5sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_name}"
+ cd "${srcdir}/${pkgbase}"
_parent_ver=$(git tag --sort=version:refname | tail -n 1 | cut -d "-" -f 2- | tr - .)
_parent_major_ver=$(echo "${_parent_ver}" | cut -d "." -f 1)
_parent_minor_ver=$(echo "${_parent_ver}" | cut -d "." -f 2)
@@ -35,32 +32,38 @@ pkgver() {
}
prepare() {
- mkdir -p "${srcdir}/build"
- cd "${srcdir}/build"
+ mkdir -p build
}
build() {
- cd "${srcdir}/build"
+ cd build
- cmake "${srcdir}/${_name}" \
- -DCMAKE_BUILD_TYPE=Release \
+ cmake "${srcdir}/${pkgbase}" \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DENABLE_OPENMP=ON \
+ -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-gtk3 \
-DRUN_SWIG=ON \
-DPYTHON_BINDINGS=ON
make
-}
-check() {
- NCPUS=$(nproc)
- cd "${srcdir}/build"
- ctest -j${NCPUS}
+ # To split python bindings
+ sed -i '/scripts.cmake_install.cmake/d' cmake_install.cmake
}
-package() {
- cd "${srcdir}"/build
+package_openbabel-git() {
+ depends=('wxgtk3' 'maeparser')
+ provides=("${pkgbase}")
+ conflicts=("${pkgbase}")
+
+ cd build
make DESTDIR="${pkgdir}" install
- cd "${srcdir}"/build/scripts
+}
+
+package_python-openbabel-git() {
+ depends=('python' 'openbabel')
+ provides=("python-${pkgbase}")
+ conflicts=("python-${pkgbase}")
+
+ cd build/scripts
make DESTDIR="${pkgdir}" install
}