summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorM0Rf302017-11-29 14:22:05 +0100
committerM0Rf302017-11-29 14:22:05 +0100
commitf6b1a016dbbdc4f32d4215354c225be832d3a18f (patch)
tree6830f89f8c3bfa4979b6e6693b30839a3c11965c /PKGBUILD
parent61de0a69f70b4b40dcdd46ae3eef9ef940b33747 (diff)
downloadaur-f6b1a016dbbdc4f32d4215354c225be832d3a18f.tar.gz
openbazaar: 2.0.18
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 1 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e009ed6b39ff..2a3f3dcc3100 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,6 +20,7 @@ build(){
cd $srcdir/$pkgname-desktop-$pkgver
npm install
npm run build
+ rm -rf {.eslint*,.travis*}
cp -rf prod/* js/
npm prune --production
}
@@ -38,18 +39,6 @@ package(){
msg2 "Installing icons and desktop menu entry"
install -Dm644 $pkgname-desktop-$pkgver/imgs/icon.png $pkgdir/usr/share/pixmaps/$pkgname.png
install -Dm644 $pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
-
- # Clean up
- find "${pkgdir}"${appdir} \
- -name "package.json" \
- -exec sed -e "s|${srcdir}/${pkgname}-${pkgver}|${appdir}|" \
- -i {} \; \
- -or -name ".*" -prune -exec rm -r '{}' \; \
- -or -name "bin" -prune -exec rm -r '{}' \; \
- -or -name "example" -prune -exec rm -r '{}' \; \
- -or -name "examples" -prune -exec rm -r '{}' \; \
- -or -name "test" -prune -exec rm -r '{}' \; \
- -or -executable -type f -exec rm -r '{}' \;
}
md5sums=('245c699cbca72ee71c7cdc1487cb285f'