summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorM0Rf302020-04-12 11:59:43 +0200
committerM0Rf302020-04-12 11:59:43 +0200
commit75743e3834a1a4ec239b2923c695329ea2a4458a (patch)
treed7fd03311b4adf84a597f93cd64a49de2e9420bb /PKGBUILD
parent357ac77a494995f4b38d7020bbf40748cea6f2c7 (diff)
downloadaur-75743e3834a1a4ec239b2923c695329ea2a4458a.tar.gz
openbazaar-git: updated
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 322498125e3b..efdc0f106f06 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgdesc="Front-end Electron application for talking with the OpenBazaar daemon (
arch=(any)
url="https://github.com/OpenBazaar/openbazaar-desktop"
license=('MIT')
-depends=('electron4')
+depends=('electron6')
makedepends=('git' 'npm')
conflicts=('openbazaar')
source=("${pkgname%%-git}::git+https://github.com/OpenBazaar/openbazaar-desktop.git"
@@ -17,10 +17,13 @@ source=("${pkgname%%-git}::git+https://github.com/OpenBazaar/openbazaar-desktop.
install=${pkgname%%-git}.install
options=('!strip')
-build(){
+prepare() {
cd $srcdir/${pkgname%%-git}
+ npm install --silent
+}
- npm install --silent
+build(){
+ cd $srcdir/${pkgname%%-git}
npm run build
}
@@ -57,5 +60,5 @@ pkgver() {
}
md5sums=('SKIP'
- 'd3904de13c80ae0769b8e686e239d4b6'
-'a278f17aa965510cadb534df49b245dd')
+ '8359716a04cff2fd8499406408b6c590'
+ 'a278f17aa965510cadb534df49b245dd')