summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoreolianoe2015-10-07 09:17:36 +0200
committereolianoe2015-10-07 09:17:36 +0200
commit40cb5ec4a9f4d6de1139d57ee8323e65028113df (patch)
tree56c1dd3b17d2e0c6e52898b5135e56d3db39fb02 /PKGBUILD
parentf2dee093885ea9fe6790fe6485ad525e25f96ffb (diff)
downloadaur-40cb5ec4a9f4d6de1139d57ee8323e65028113df.tar.gz
Remove the detection of the number of threads
As the number of threads is correctly detected internally
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 2 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b928d7836a63..0f42ba792016 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=openblas-lapack
_pkgname=OpenBLAS
pkgver=0.2.14
-pkgrel=4
+pkgrel=5
pkgdesc="Optimized BLAS library based on GotoBLAS2 1.13 BSD (providing blas, lapack, and cblas)"
arch=('i686' 'x86_64')
url="http://xianyi.github.com/OpenBLAS/"
@@ -23,11 +23,7 @@ _config="FC=gfortran USE_OPENMP=0 USE_THREAD=1 MAJOR_VERSION=3 NO_LAPACK=0"
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- NPROC=`grep "physical id" /proc/cpuinfo|sort|uniq|wc -l`
- NCORE4PROC=`grep "cores" /proc/cpuinfo|sort|tail -n 1|sed -e 's/cpu cores.*: //'`
- let NCORE=NPROC*NCORE4PROC
-
- make ${_config} NUM_THREADS=${NCORE} libs netlib shared
+ make ${_config} libs netlib shared
}
check() {