summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrew Anderson2018-12-14 09:52:49 +0000
committerAndrew Anderson2018-12-14 09:52:49 +0000
commit78274c6bdd6c707a57e6fea32197e11f066d835f (patch)
tree14bb3ffb5d70cb0cf35d24a276c6c6b5dadc043c /PKGBUILD
parent1f3a34e6c76ffaf27046d472a7fe2796f5273c3c (diff)
downloadaur-78274c6bdd6c707a57e6fea32197e11f066d835f.tar.gz
0.3.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 293696eafeb5..5e0feec0b8ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,10 +6,10 @@
pkgname=openblas-lapack-openmp
_PkgName=OpenBLAS
_pkgname=openblas
-pkgver=0.3.3
+pkgver=0.3.4
# grep VERSION "${srcdir}/${_PkgName}-${pkgver}"/lapack-netlib/README.md | tail -n 1 | cut -d ' ' -f 2
_lapackver=3.8.0
-pkgrel=3
+pkgrel=0
pkgdesc="Optimized BLAS library based on GotoBLAS2 1.13 BSD (providing blas, lapack, and cblas)"
arch=('any')
url="http://www.openblas.net/"
@@ -20,14 +20,13 @@ provides=('openblas' "blas=${_lapackver}" "lapack=${_lapackver}" "cblas=${_lapac
conflicts=('openblas' 'blas' 'lapack' 'cblas' 'lapacke')
options=(!emptydirs)
source=(${_PkgName}-${pkgver}.tar.gz::https://github.com/xianyi/${_PkgName}/archive/v${pkgver}.tar.gz)
-sha256sums=('49d88f4494ae780e3d7fa51769c00d982d7cdb73e696054ac3baa81d42f13bab')
-
-# Add the following line to the _config variable if you want to set the number of make jobs
-# MAKE_NB_JOBS=2 \
+sha256sums=('SKIP')
_config="FC=gfortran USE_OPENMP=1 USE_THREAD=1 \
USE_COMPILER_TLS=0 \
- NO_LAPACK=0 BUILD_LAPACK_DEPRECATED=1"
+ NO_LAPACK=0 BUILD_LAPACK_DEPRECATED=1" \
+ MAKE_NB_JOBS=`cat /proc/cpuinfo | grep processor | wc -l` \
+
build(){
cd "${srcdir}/${_PkgName}-${pkgver}"