summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichał Walenciak2020-05-19 20:52:08 +0200
committerMichał Walenciak2020-05-19 20:52:08 +0200
commit0f842a2fc5d845c93b5fa7958cef2298e9138599 (patch)
tree4748f3f7aa2a939b9e36facc14202e09f4f04109 /PKGBUILD
parent7cab778dac4c8d1fdb686b2fb342a6984160c60b (diff)
downloadaur-0f842a2fc5d845c93b5fa7958cef2298e9138599.tar.gz
bumping version to 0.8.2
- adding SDL dependencies - removing useless patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 45cd13f38882..9a78acd96f14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,16 @@
# Maintainer: Michał Walenciak <kicer86@gmail.com>
pkgname=openblok
-pkgver=0.7.0
-pkgrel=3
+pkgver=0.8.2
+pkgrel=1
pkgdesc="A customizable, cross platform, open-source falling block game, packed with a bunch of features."
arch=('i686' 'x86_64')
url="https://github.com/mmatyas/openblok"
license=('GPL3')
groups=()
-depends=()
+depends=('sdl2'
+ 'sdl2_image'
+ 'sdl2_mixer'
+ 'sdl2_ttf')
makedepends=('cmake')
optdepends=()
provides=()
@@ -17,15 +20,15 @@ backup=()
options=()
install=
changelog=
-source=(https://codeload.github.com/mmatyas/$pkgname/tar.gz/v$pkgver 0001-Fixed-AppImage-data-path.patch)
+source=(https://codeload.github.com/mmatyas/$pkgname/tar.gz/v$pkgver libSDL2pp::git+https://github.com/mmatyas/libSDL2pp.git#branch=cmake_modernization)
noextract=()
-md5sums=('0c82fadc6573e4fa0fe84171d169d978'
- '47cb3991c7997149f9229230969342ee')
+md5sums=('6dd426a1dec30c74036ae09113505659'
+ 'SKIP')
build()
{
+ mv ./libSDL2pp/* $pkgname-$pkgver/thirdparty/libSDL2pp
cd "$pkgname-$pkgver"
- patch --forward --strip=1 --input="${srcdir}/0001-Fixed-AppImage-data-path.patch"
mkdir -p build
cd build
cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DEXEDIR=/usr/bin