summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichał Walenciak2019-03-09 12:47:44 +0100
committerMichał Walenciak2019-03-09 12:47:44 +0100
commite7c7632cd4299c7af87719c651ac3685fdcd667d (patch)
tree04018488e996acd9ebb6189c03597cc45bb6fcfc /PKGBUILD
downloadaur-e7c7632cd4299c7af87719c651ac3685fdcd667d.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d31bb758adad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Michał Walenciak <kicer86@gmail.com>
+pkgname=openblok
+pkgver=0.7.0
+pkgrel=1
+pkgdesc="A customizable, cross platform, open-source falling block game, packed with a bunch of features."
+arch=('i686' 'x86_64')
+url="https://github.com/mmatyas/openblok"
+license=('GPL3')
+groups=()
+depends=('')
+makedepends=('cmake')
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(https://codeload.github.com/mmatyas/$pkgname/tar.gz/v$pkgver)
+noextract=()
+md5sums=('0c82fadc6573e4fa0fe84171d169d978')
+
+build()
+{
+ cd "$pkgname-$pkgver"
+ mkdir -p build
+ cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DEXEDIR=/usr/bin
+ make
+}
+
+package()
+{
+ cd "$pkgname-$pkgver"
+ cd build
+ make DESTDIR="$pkgdir/" install
+}