summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrederik Schwan2023-12-12 13:39:20 +0100
committerFrederik Schwan2023-12-12 13:39:20 +0100
commit56c1f579d1b64fa1943830b6d17b87b75dccb727 (patch)
treecfa6d4f10eb9ac0cdedeb1cbe8fbf37003f979fd /PKGBUILD
parentd1cc410ad67e8f474368a16f7b854312fee5027c (diff)
downloadaur-openboardview.tar.gz
gcc 13 fixes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ec929842bc11..11b79a777248 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=OpenBoardView
pkgname=${_pkgname,,}
pkgver=9.95.0
-pkgrel=1
+pkgrel=2
pkgdesc='Linux SDL/ImGui edition software for viewing .brd files'
arch=('i686' 'x86_64')
url='https://openboardview.org/'
@@ -17,6 +17,7 @@ source=("git+https://github.com/OpenBoardView/OpenBoardView.git#tag=${pkgver}"
'git+https://github.com/nothings/stb.git'
'git+https://github.com/sheredom/utf8.h.git'
'git+https://github.com/madler/zlib.git'
+ 'gcc13.patch::https://github.com/OpenBoardView/OpenBoardView/commit/b03d0f69ec1611f5eb93f81291b4ba8c58cd29eb.diff'
)
b2sums=('SKIP'
'SKIP'
@@ -24,7 +25,8 @@ b2sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP')
+ 'SKIP'
+ '81aa5ce1297d2e54ffca843bfd3a5ca7d3c1039e1f7f65560eb54b6de87876ae5705d058c371921d26384177373d23639ce0acbaf8ffd15faf201b7f04ffcb3c')
prepare() {
cd ${_pkgname}
@@ -37,6 +39,7 @@ prepare() {
git config submodule.'src/utf8'.url "${srcdir}"/utf8.h
git config submodule.'src/zlib'.url "${srcdir}"/zlib
git -c protocol.file.allow=always submodule update --recursive
+ git apply "$srcdir/gcc13.patch"
}
build() {