summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartin Filion2024-01-27 21:19:00 -0500
committerMartin Filion2024-01-27 21:19:00 -0500
commit52d1023940a0ae1b975deb791b22952310da6df8 (patch)
tree56e0737f9c5f436301d148cf6d9dcdc69fa28784 /PKGBUILD
parent0b63e79f781f7bb03e62fe94cf213e89a601027e (diff)
downloadaur-52d1023940a0ae1b975deb791b22952310da6df8.tar.gz
added lxterminal as dep. include patches to have lxterminal instead of xterm for terminal apps
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 12 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b5cc6729ce2a..2897a2fe0d64 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,30 @@
# Contributors: Calimero <calimeroteknik@free.fr>
# Maintainer: mimas <mimasgpc@free.fr>
-# Last Modified 2023-01-23 by Martin Filion <Mordillo98@gmail.com>
+# Last Modified 2024-01-27 by Martin Filion <Mordillo98@gmail.com>
pkgname=openbox-menu
pkgver=0.8.0
-pkgrel=1
+pkgrel=2
pkgdesc="Dynamic XDG menu for openbox"
arch=('i686' 'x86_64')
url="http://fabrice.thiroux.free.fr/openbox-menu_en.html"
license=('GPL3')
-depends=('gtk2' 'menu-cache')
+depends=('gtk2' 'menu-cache' 'lxterminal')
optdepends=('lxmenu-data: LXDE menus' 'gnome-menus: GNOME menus')
-source=("git+https://github.com/fabriceT/openbox-menu" "with-svg.patch")
+source=("git+https://github.com/fabriceT/openbox-menu" "with-svg.patch" "openbox-menu.patch" "menu.patch")
md5sums=('SKIP'
- '484bd49f619e57f9fb2be42931d57dd5')
+ '484bd49f619e57f9fb2be42931d57dd5'
+ '1a74746fcf8b24f76fc79c61d1533db0'
+ '5d92e49ed689ada8b2a02b04cc50a4b0')
build() {
cd "${srcdir}/${pkgname}"
patch -i ../with-svg.patch
+
+ # Uses Lxterminal instead of xterm for terminal apps.
+ patch src/menu.c < ../menu.patch
+ patch src/openbox-menu.h < ../openbox-menu.patch
+
make
}