summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYuval Adam2015-06-30 15:51:33 +0300
committerYuval Adam2015-06-30 15:51:33 +0300
commit1056817fc0e45febdb86c1e1adc391f528b38217 (patch)
tree18fbdcf8f1dda299767a69689b974853d27238a2 /PKGBUILD
downloadaur-1056817fc0e45febdb86c1e1adc391f528b38217.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..29606bba556e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Yuval Adam <yuval at y3xz dot com> PGP-Key: 271386AA2EB7672F
+
+pkgname=openbsc
+pkgver=0.14.0
+pkgrel=1
+pkgdesc="Free software implementations for the GSM/G3PP protocol stacks"
+arch=('any')
+url="http://openbsc.osmocom.org"
+license=(GPL)
+depends=('libdbi' 'libdbi-drivers' 'ortp' 'libosmocore' 'libosmo-abis' 'libosmo-netif')
+optdepends=('libosmo-sccp: for building BSC NAT')
+source=("git://git.osmocom.org/${pkgname}.git#tag=${pkgver}")
+sha256sums=('SKIP')
+
+build() {
+ cd "${srcdir}/${pkgname}/${pkgname}"
+ autoreconf -i
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}/${pkgname}"
+ make DESTDIR=${pkgdir} install
+}
+
+# vim:set ts=2 sw=2 et: