summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdam Goldsmith2017-03-12 11:50:49 -0400
committerAdam Goldsmith2017-03-12 11:50:49 -0400
commitb8d1cfe1287224684a0ceb34402a629e7ba6205d (patch)
treec9034cc3b9e91b4dca2b81761d3a61c4efddbe19 /PKGBUILD
parent7c3f534dcc8419f8ed88f19c4c67319543e39ab5 (diff)
downloadaur-b8d1cfe1287224684a0ceb34402a629e7ba6205d.tar.gz
Drop CmakeLists patch entirely, as a fix was merged upstream
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 4 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a963896136f4..c44f6afb16d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
pkgname=opencamlib-git
-pkgver=11.10.73.g30ed446
+pkgver=11.10.84.gc2bcbbd
pkgrel=1
pkgdesc="Multi-Purpose CNC Toolpath Library"
arch=('i686' 'x86_64')
@@ -11,23 +11,18 @@ makedepends=('boost' 'cmake' 'doxygen')
depends=('python2' 'boost')
provides=('opencamlib')
conflicts=('opencamlib')
-source=("git+https://github.com/aewallin/opencamlib.git" 'CMakeLists.txt.patch')
-md5sums=('SKIP' '84af9224f4e3929afe447e843094b103')
+source=("git+https://github.com/aewallin/opencamlib.git")
+md5sums=('SKIP')
pkgver() {
cd opencamlib
git describe --tags | sed 's/-/./g'
}
-prepare() {
- cd "$srcdir/opencamlib/src"
- patch < $srcdir/CMakeLists.txt.patch
-}
-
build() {
mkdir "$srcdir/opencamlib/build"
cd "$srcdir/opencamlib/build"
- cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ../src
make
}