summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdam Goldsmith2016-08-03 01:43:35 -0400
committerAdam Goldsmith2016-08-03 01:43:35 -0400
commitbe33fa94600563c905d5f414559f16b682ab7723 (patch)
treed56edc9828ac4cc11b5c3193aa0beccd47baaa11 /PKGBUILD
parenta3441314888d62146a38cd476629c5f2e7c4d523 (diff)
downloadaur-be33fa94600563c905d5f414559f16b682ab7723.tar.gz
Get version from git tags
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 26d54df83949..b827d9dd8c15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
pkgname=opencamlib-git
-pkgver=1
+pkgver=11.10.64.g89c21a2
pkgrel=1
pkgdesc="Multi-Purpose CNC Toolpath Library"
arch=('i686' 'x86_64')
@@ -14,6 +14,11 @@ conflicts=('opencamlib')
source=("git+https://github.com/aewallin/opencamlib.git" 'CMakeLists.txt.patch')
md5sums=('SKIP' 'c76fcdacce09047308509caf50a8cd5a')
+pkgver() {
+ cd opencamlib
+ git describe --tags | sed 's/-/./g'
+}
+
prepare() {
cd "$srcdir/opencamlib/src"
patch < $srcdir/CMakeLists.txt.patch