summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrey Christoforo2021-05-03 16:35:54 +0200
committerGrey Christoforo2021-05-03 16:35:54 +0200
commit7a6f009f6961d18b49e69848414fb3c2d0b5136a (patch)
tree8851b8bff6b356a3545d20b5d69a30cb888e9542 /PKGBUILD
parent0e59abb849a6197057e99d3812fde431b83c5e57 (diff)
downloadaur-7a6f009f6961d18b49e69848414fb3c2d0b5136a.tar.gz
fix a freecad bug.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 93ee98819db3..f2b42d700287 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=opencascade-rc
_pkgver="V7_5_2"
pkgver=$(echo ${_pkgver} | sed 's,^V,,g;s,_,.,g')
-pkgrel=1
+pkgrel=2
pkgdesc="An object-oriented C++ class library designed for rapid production of sophisticated domain-specific CAD/CAM/CAE applications -- release candidates and dev snapshots"
arch=(x86_64)
url="https://dev.opencascade.org/"
@@ -14,7 +14,8 @@ conflicts=(opencascade opencascade-git)
depends=(
tk
-vtk9-java
+vtk
+#vtk9-java
gl2ps
ffmpeg
freeimage
@@ -52,6 +53,9 @@ prepare() {
# fix for trying to write into the system during build
sed 's,if (EXISTS "${INSTALL_DIR}/${INSTALL_DIR_SCRIPT}/custom.${SCRIPT_EXT}"),if (0),g' -i CMakeLists.txt
+
+ # fix for https://tracker.dev.opencascade.org/view.php?id=32328
+ sed 's,#include <TopoDS_Shape.hxx>,#include <TopoDS_Edge.hxx>\n#include <TopoDS_Shape.hxx>,g' -i src/ShapeUpgrade/ShapeUpgrade_UnifySameDomain.hxx
}
build() {