summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLukas Werling2016-01-19 16:50:46 +0100
committerLukas Werling2016-01-19 17:38:29 +0100
commit835877dc9fcfb90bc812f1a7280ce53fffeb6fb5 (patch)
treee6949029850e368e3209faf43b631b0e84fae36f /PKGBUILD
parent3983fe18e235f30d765d9f725c369033c703d5be (diff)
downloadaur-835877dc9fcfb90bc812f1a7280ce53fffeb6fb5.tar.gz
Install unpacked music to allow adding more music
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aea7654b0a3a..e0e2ab99f30e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,11 @@
# Contributor: Jonathan Steel <mail at jsteel dot org>
# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
# Contributor: Wesley <rudirennsau at hotmail dot com>
+# Contributor: Lukas Werling <lukas.werling@gmail.com>
pkgname=openclonk
pkgver=7.0
-pkgrel=2
+pkgrel=3
_orig=$pkgname-$pkgver-src
pkgdesc='Multiplayer-action-tactic-skill game'
arch=('i686' 'x86_64')
@@ -13,6 +14,7 @@ url='http://openclonk.org'
license=('custom')
depends=('gtk2' 'glew' 'sdl_mixer' 'libxpm' 'hicolor-icon-theme' 'libupnp')
makedepends=('cmake' 'boost' 'imagemagick' 'mesa')
+optdepends=('openclonk-music: proprietary music package')
conflicts=('clonk_rage')
install=$pkgname.install
source=("http://openclonk.org/builds/release/$pkgver/$pkgname-$pkgver-src.tar.bz2" 'directories.patch')
@@ -40,6 +42,10 @@ package() {
make DESTDIR="$pkgdir" install
+ # Replace the music packet with unpacked music to allow adding music.
+ rm "$pkgdir/usr/share/openclonk/Music.ocg"
+ install -Dm644 ../planet/Music.ocg/* -t "$pkgdir/usr/share/openclonk/Music.ocg"
+
# licenses
install -dm755 "$pkgdir"/usr/share/licenses/$pkgname
install -m644 ../licenses/*.txt "$pkgdir"/usr/share/licenses/$pkgname