summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLászló Várady2021-10-27 20:56:54 +0200
committerLászló Várady2021-10-27 20:56:54 +0200
commit448fe9a845c232c48588beaa1c287bef81238bf6 (patch)
tree7a65d94d56f17d028a44134624582d48724d02cf /PKGBUILD
parent3ccb072aa404938fc5f2f4e7cda0dc21377f3083 (diff)
downloadaur-448fe9a845c232c48588beaa1c287bef81238bf6.tar.gz
Relax structlog version constraints
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a671d451fd0f..f782fea755ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=openconnect-sso
pkgver=0.7.3
-pkgrel=1
+pkgrel=2
pkgdesc="Wrapper script for OpenConnect supporting Azure AD (SAMLv2) authentication"
arch=('any')
url="https://github.com/vlaci/openconnect-sso"
@@ -13,8 +13,15 @@ depends=('python' 'python-pyqt5' 'python-pyqtwebengine' 'python-attrs' 'python-c
makedepends=('python-setuptools')
checkdepends=('python-pytest' 'python-pytest-asyncio')
optdepends=()
-source=("https://github.com/vlaci/openconnect-sso/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz")
-sha256sums=('4159d133ea7d27a61f958479c3d551f9f2a5a825c91cdef405500284112bba18')
+source=("https://github.com/vlaci/openconnect-sso/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
+ 'relax-structlog-version-constraints.patch')
+sha256sums=('4159d133ea7d27a61f958479c3d551f9f2a5a825c91cdef405500284112bba18'
+ '2f09b062f41eeb09721d8b1063ece3f620e5f947bdfb82262fb6b862f581ea89')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch --forward --strip=1 --input="${srcdir}/relax-structlog-version-constraints.patch"
+}
build() {
cd "$pkgname-$pkgver"