summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRomain Bazile2021-03-07 15:18:54 +0100
committerRomain Bazile2021-03-07 15:18:54 +0100
commit586f518468fbf841e9b729452c05d91b3c9bb631 (patch)
tree440c66b0b41089e1e624d7e92a99099e7cfb5936 /PKGBUILD
parent546bce3e9a6a4745f5247bbdd5181eef6589d680 (diff)
downloadaur-opencpn-plugin-oesenc-git.tar.gz
update to latest git revision
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d96dbb9385bf..b989bef55b70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# ---------------------------------------------------------------
pkgname=opencpn-plugin-oesenc-git
-pkgver=4.0.5.r117.ga6e904c
+pkgver=4.0.5.r229.g5594ae3
pkgrel=1
pkgdesc="O-charts.org plugin for OpenCPN"
arch=('x86_64' 'aarch64')
@@ -12,9 +12,9 @@ depends=('opencpn')
conflicts=('opencpn-plugin-oesenc')
makedepends=('cmake' 'git')
url="https://opencpn.org/OpenCPN/plugins/oesenc.html"
-source=("$pkgname::git+https://github.com/bdbcat/oesenc_pi.git" "CMakeLists.patch")
+source=("$pkgname::git+https://github.com/bdbcat/oesenc_pi.git" "GetArch.cmake.patch")
sha1sums=('SKIP'
- 'ef99cd55434a26699a6a35a78bbcd357719ac430')
+ '4610b7215572c45ad0f8e696a1920053bdee32ad')
pkgver() {
cd $pkgname
@@ -23,16 +23,15 @@ pkgver() {
build() {
cd $pkgname
- patch --strip=1 --binary -i $srcdir/CMakeLists.patch
+ patch --strip=1 --binary -i $srcdir/GetArch.cmake.patch
mkdir -p build
cd build
cmake -DCMAKE_INSTALL_PREFIX=/usr -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-gtk3 ..
- make
+ make pkg
}
package() {
cd "$pkgname/build"
DESTDIR="$pkgdir" make install
- mkdir -p $pkgdir/etc/udev/rules.d
- install -m 644 $srcdir/$pkgname/buildlinux/oeserverd/98-sglock.rules $pkgdir/etc/udev/rules.d/
+ mv $pkgdir/usr/etc $pkgdir/
}