summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRomain Bazile2020-07-03 21:12:15 +0200
committerRomain Bazile2020-07-03 21:12:15 +0200
commit692d50715c2ff521601c4ef9e1bbd4a6a61df7f0 (patch)
treeafbc9ccbaff6491ebbfc21768d53d5a658abd70d /PKGBUILD
parent9acf7611ea002baafc8282cd306dba5386ab3c2f (diff)
downloadaur-692d50715c2ff521601c4ef9e1bbd4a6a61df7f0.tar.gz
update to fix build for arm
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0f5e61a34d4a..cec36d7889e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=opencpn-plugin-oesenc-git
pkgver=4.0.5.r112.gaa16607
-pkgrel=1
+pkgrel=2
pkgdesc="O-charts.org plugin for OpenCPN"
arch=('x86_64' 'aarch64')
license=("GPL3")
@@ -14,7 +14,7 @@ makedepends=('cmake' 'git')
url="https://opencpn.org/OpenCPN/plugins/oesenc.html"
source=("$pkgname::git+https://github.com/bdbcat/oesenc_pi.git" "CMakeLists.patch")
sha1sums=('SKIP'
- 'ee6eed6c699f37897c927d8a81a93da8abdf7b91')
+ 'ef99cd55434a26699a6a35a78bbcd357719ac430')
pkgver() {
cd $pkgname
@@ -23,7 +23,7 @@ pkgver() {
build() {
cd $pkgname
- patch --strip=1 $srcdir/CMakeLists.patch
+ patch --strip=1 --binary -i $srcdir/CMakeLists.patch
mkdir -p build
cd build
cmake -DCMAKE_INSTALL_PREFIX=/usr -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-gtk3 ..