summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRomain Bazile2020-07-03 15:26:16 +0200
committerRomain Bazile2020-07-03 15:26:16 +0200
commit9acf7611ea002baafc8282cd306dba5386ab3c2f (patch)
treefaab4b5e1684f75590c2126d07616aa859cae368 /PKGBUILD
parentf489c1c197aed2eaefe7bd9c91c390d8d9bbda41 (diff)
downloadaur-9acf7611ea002baafc8282cd306dba5386ab3c2f.tar.gz
fix build on arm64
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 48ec7e412ee9..0f5e61a34d4a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,8 +12,9 @@ depends=('opencpn')
conflicts=('opencpn-plugin-oesenc')
makedepends=('cmake' 'git')
url="https://opencpn.org/OpenCPN/plugins/oesenc.html"
-source=("$pkgname::git+https://github.com/bdbcat/oesenc_pi.git")
-sha1sums=('SKIP')
+source=("$pkgname::git+https://github.com/bdbcat/oesenc_pi.git" "CMakeLists.patch")
+sha1sums=('SKIP'
+ 'ee6eed6c699f37897c927d8a81a93da8abdf7b91')
pkgver() {
cd $pkgname
@@ -22,6 +23,7 @@ pkgver() {
build() {
cd $pkgname
+ patch --strip=1 $srcdir/CMakeLists.patch
mkdir -p build
cd build
cmake -DCMAKE_INSTALL_PREFIX=/usr -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-gtk3 ..