summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBaptiste Jonglez2016-06-02 22:57:01 +0200
committerBaptiste Jonglez2016-06-02 22:57:42 +0200
commitd7ccb85145de43e48f0d746a67d06b25be774042 (patch)
tree1c38c736d7598d62866322d5f1e787237c643fd0 /PKGBUILD
parent349ea6f1e347f44e48445a691cf0acfb84b1a93b (diff)
downloadaur-d7ccb85145de43e48f0d746a67d06b25be774042.tar.gz
opendht: Build python bindings
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4928919b9c48..9198941c2597 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Maintainer: Baptiste Jonglez <baptiste--aur at jonglez dot org>
# Contributor: Andy Weidenbaum <archbaum@gmail.com>
pkgname=opendht-git
-pkgver=20160530
+pkgver=20160602
pkgrel=1
pkgdesc="A C++11 implementation of the Kademlia DHT (Distributed Hash Table)"
arch=('i686' 'x86_64')
depends=('gnutls' 'nettle' 'readline')
-makedepends=('git' 'msgpack-c' 'cmake')
+makedepends=('git' 'msgpack-c' 'cmake' 'cython')
+optdepends=('python: to use the Python bindings')
url="https://github.com/savoirfairelinux/opendht"
license=('GPL3')
source=("git://github.com/savoirfairelinux/opendht")
@@ -27,6 +28,7 @@ build() {
cd build
cmake .. \
-DCMAKE_BUILD_TYPE=Release \
+ -DOPENDHT_PYTHON=ON \
-DCMAKE_INSTALL_PREFIX=/usr
make
}