summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorshinnova2016-09-08 17:20:09 +0200
committershinnova2016-09-08 17:21:52 +0200
commit1fec97d0b0715dc2799dd06889f4f47fa9857811 (patch)
tree78c4e2a1ce81a61ebc69d6be53ce73689a09820a /PKGBUILD
downloadaur-1fec97d0b0715dc2799dd06889f4f47fa9857811.tar.gz
Bringing 'OpenDungeons' to the AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f2ce4e26ac10
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Ivanka Heins (ivanka@tuta.io)
+
+pkgname="opendungeons"
+pkgver="0.7.1"
+_pkgname="OpenDungeons-${pkgver}-Linux64"
+pkgrel="1"
+pkgdesc="Open source, real time strategy game sharing game elements with the Dungeon Keeper series and Evil Genius"
+arch=('x86_64')
+url="https://opendungeons.github.io"
+options=('!strip')
+license=("GPL3")
+depends=("zziplib")
+source=("ftp://download.tuxfamily.org/opendungeons/0.7/OpenDungeons-0.7.1-Linux64.tar.bz2"
+ "opendungeons_startup")
+md5sums=("ad05df375a5f0b720120147975029229"
+ "a9b6e78b78d09e07b87a76b36ffa6969")
+
+package() {
+ cd $srcdir
+ mkdir -p "${pkgdir}/opt"
+ mkdir -p "${pkgdir}/usr/bin"
+ cp -r $_pkgname/ "${pkgdir}/opt/${pkgname}"
+ install -Dm755 opendungeons_startup "${pkgdir}/usr/bin/${pkgname}"
+}
+