summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlban Fichet2019-11-25 18:20:13 +0100
committerAlban Fichet2019-11-25 18:20:13 +0100
commit7648b13704a3006d8fa6c42c013299fbf9b8651d (patch)
treeac52fa39a296e81169d71076c320dea745256981 /PKGBUILD
downloadaur-7648b13704a3006d8fa6c42c013299fbf9b8651d.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..17ccca76332d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Alban Fichet <alban.fichet@inria.fr>
+pkgname=openexr-thumbnailer
+pkgver=1.0
+pkgrel=1
+pkgdesc="Tool to display thumbnails for OpenEXR images in your file manager."
+arch=('any')
+url="https://github.com/yama-chan/openexr-thumbnailer"
+license=('GPL')
+depends=('gnome-common' 'glib2' 'gdk-pixbuf2' 'openexr')
+makedepends=()
+checkdepends=()
+provides=($pkgname=$pkgver)
+source=("$pkgname::git+https://github.com/yama-chan/$pkgname.git")
+md5sums=('SKIP')
+
+prepare() {
+ cd "$pkgname"
+}
+
+build() {
+ cd "$pkgname"
+ ./autogen.sh --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir/" install
+}