summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid McKay2018-04-25 11:06:21 +0100
committerDavid McKay2018-04-25 11:25:47 +0100
commiteb88bf8fd376943c58caa133b67fc7415283226e (patch)
treefa9cc94707ea28b7aecb6b3979f24968cc67d7b8 /PKGBUILD
parent9e421ea4f8f6b15806ebec8faa404a17cbe74bb0 (diff)
downloadaur-eb88bf8fd376943c58caa133b67fc7415283226e.tar.gz
Releasing 0.6.8
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c2bd28829dbf..7fb79f7fe5c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,21 @@
pkgname=openfaas-cli
pkgdesc="OpenFaaS CLI"
-pkgver=0.4.30
+pkgver=0.6.8
pkgrel=1
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'arm64')
url="https://github.com/openfaas/faas-cli"
license=('mit')
-makedepends=('go')
+makedepends=('go' 'godep')
source=("https://github.com/openfaas/faas-cli/archive/$pkgver.tar.gz")
-sha256sums=('10a844c8f92fdcf843107170a3d1e101d89afd1bb25c05d898748f1e97239271')
+sha256sums=('c9bab5c1ed2bab75339745439f30e40362fe1b2d3cf05518b569b5683c66ac68')
build() {
cd "$srcdir/faas-cli-$pkgver"
- VERSION=$(git describe --all --exact-match `git rev-parse HEAD` | grep tags | sed 's/tags\///')
- GIT_COMMIT=$(git rev-list -1 HEAD)
- CGO_ENABLED=0 GOOS=linux go build --ldflags "-s -w -X github.com/openfaas/faas-cli/commands.GitCommit=${GIT_COMMIT} -X github.com/openfaas/faas-cli/commands.Version=${VERSION}" -a -installsuffix cgo -o faas-cli .
+ dep ensure
+ CGO_ENABLED=0 GOOS=linux go build --ldflags "-s -w -X github.com/openfaas/faas-cli/version.Version=$pkgver" -a -installsuffix cgo -o faas-cli
}
package() {