diff options
author | Charles DELFLY | 2019-08-24 13:08:41 +0700 |
---|---|---|
committer | Charles DELFLY | 2019-08-24 13:08:41 +0700 |
commit | eb08c0e4d610ea5167a2ec61f99428bb3a892172 (patch) | |
tree | f9ac2453e1cf6374923abd0051e770c94d127431 /PKGBUILD | |
parent | e3ae49ebe06fef2381719a5cd78241cf12766a1a (diff) | |
download | aur-eb08c0e4d610ea5167a2ec61f99428bb3a892172.tar.gz |
Add lightman patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 42 |
1 files changed, 22 insertions, 20 deletions
@@ -1,7 +1,7 @@ # Maintainer: Charles Delfly <charles@delfly.fr> pkgname=openfortigui pkgver=0.8.0 -pkgrel=1 +pkgrel=2 pkgdesc="OpenFortiGUI is an open-source VPN-Client to connect to Fortigate VPN-Hardware. It is based on openfortivpn and adds an easy to use and nice GUI on top of it, written in Qt5." arch=('i686' 'x86_64') url="https://github.com/theinvisible/openfortigui.git" @@ -14,38 +14,40 @@ conflicts=() replaces=() options=() install= -source=("git+https://github.com/theinvisible/$pkgname.git#tag=v$pkgver") +source=("git+https://github.com/theinvisible/$pkgname.git#tag=v$pkgver" "user-env.patch") #source=("git+https://github.com/theinvisible/$pkgname.git#commit=3f3143ffeeba8671320ac286de64dcfef47820c7") noextract=() -md5sums=('SKIP') +md5sums=('SKIP' 'be12ed116cb5a39c69e8f0da7ff67db7') prepare() { - cd "$srcdir/$pkgname" + cd "$srcdir/$pkgname" + ls -la + cd openfortigui + git submodule init + git submodule update + cd .. + # patch from lightman to allows the client to run in the user environment (https://aur.archlinux.org/packages/openfortigui/#comment-701294) + git apply ../user-env.patch } build() { - cd "$srcdir/$pkgname" - cd openfortigui - git submodule init - git submodule update - cd .. - qmake - make -j4 + cd "$srcdir/$pkgname" + qmake + make -j4 } - check() { - cd "$srcdir/$pkgname" - make -k check + cd "$srcdir/$pkgname" + make -k check } package() { - cd "$srcdir/$pkgname/openfortigui" - mkdir -p $pkgdir/usr/bin $pkgdir/usr/share/pixmaps $pkgdir/usr/share/applications $pkgdir/etc/sudoers.d $pkgdir/etc/openfortigui/vpnprofiles - install -m 755 openfortigui $pkgdir/usr/bin/ - install -m 440 sudo/openfortigui $pkgdir/etc/sudoers.d - install -m 644 app-entry/openfortigui.png $pkgdir/usr/share/pixmaps/ - install -m 644 app-entry/openfortigui.desktop $pkgdir/usr/share/applications/ + cd "$srcdir/$pkgname/openfortigui" + mkdir -p $pkgdir/usr/bin $pkgdir/usr/share/pixmaps $pkgdir/usr/share/applications $pkgdir/etc/sudoers.d $pkgdir/etc/openfortigui/vpnprofiles + install -m 755 openfortigui $pkgdir/usr/bin/ + install -m 440 sudo/openfortigui $pkgdir/etc/sudoers.d + install -m 644 app-entry/openfortigui.png $pkgdir/usr/share/pixmaps/ + install -m 644 app-entry/openfortigui.desktop $pkgdir/usr/share/applications/ } |