summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaciej Ɓotysz2017-05-19 15:30:14 +0200
committerPatrick Hanft2017-05-20 14:46:30 +0200
commit14408c345797163ad637b0884f84d81761759982 (patch)
treeb04ccbbfc4a483aea06bbc888576ab9d516aac33 /PKGBUILD
parent96a924eef321c8e8994c625f5955f27808474435 (diff)
downloadaur-14408c345797163ad637b0884f84d81761759982.tar.gz
Fix building error - workaround
https://github.com/adrienverge/openfortivpn/issues/81
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5dbbb114afa5..f8985aff689d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,9 +15,15 @@ replaces=()
backup=('etc/openfortivpn/config')
options=()
install=
-source=("git+https://github.com/adrienverge/$pkgname.git#tag=v$pkgver")
+source=("git+https://github.com/adrienverge/$pkgname.git#tag=v$pkgver" "allow-no-unused-functions.patch")
noextract=()
-md5sums=('SKIP')
+md5sums=('SKIP'
+ '4ce932a43c5b6e7241fb3e7ccc7a199f')
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ patch -Np0 -i "${srcdir}/allow-no-unused-functions.patch"
+}
build() {
cd "$srcdir/$pkgname"